How do I resolve peer dependency error: The package react@15.3.2 does not satisfy its siblings' peerDependencies requirements

Go To


I am getting this error when I run npm install. This seems because I am unable to satisfy some peer dependency but I am unsure which peer dependency I need to fix.

λ npm install

npm ERR! Windows_NT 10.0.14393
npm ERR! argv "C:\\Program Files\\nodejs\\node.exe" "C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "install"
npm ERR! node v4.6.0
npm ERR! npm  v2.15.9

npm ERR! peerinvalid The package react@15.3.2 does not satisfy its siblings' peerDependencies requirements!
npm ERR! peerinvalid Peer belle@2.0.7 wants react@>=0.14.0 || ^15.0.0-rc
npm ERR! peerinvalid Peer material-ui@0.15.4 wants react@^15.0.0
npm ERR! peerinvalid Peer react-infinite@0.9.2 wants react@^15.0.0
npm ERR! peerinvalid Peer react-input-field@1.2.4 wants react@>=0.12.0
npm ERR! peerinvalid Peer react-router@0.13.6 wants react@0.13.x || 0.14.x || ^15.0.1
npm ERR! peerinvalid Peer react-tap-event-plugin@0.2.2 wants react@^0.14.0
npm ERR! peerinvalid Peer react-toolbox@1.2.1 wants react@~0.14 || ~15.3.0
npm ERR! peerinvalid Peer react-addons-css-transition-group@15.3.2 wants react@^15.3.2
npm ERR! peerinvalid Peer react-dom@15.3.2 wants react@^15.3.2

npm ERR! Please include the following file with any support request:
npm ERR!     C:\Users\Daljeet\Documents\hive\client\npm-debug.log

I have also attached a copy of the package.json


  "dependencies": {
    "belle": "^2.0.7",
    "body-parser": "^1.6.5",
    "bootstrap": "^3.3.0",
    "compression": "^1.0.11",
    "config": "^1.21.0",
    "config-js": "^1.1.9",
    "connect-ensure-login": "^0.1.1",
    "cors": "^2.4.1",
    "dateformat": "^1.0.12",
    "dotenv": "^0.4.0",
    "errorhandler": "^1.1.1",
    "express": "^4.8.5",
    "express-jwt": "^0.3.1",
    "flux": "^2.0.1",
    "i": "^0.3.5",
    "immutability-helper": "^2.0.0",
    "jsonwebtoken": "^5.0.1",
    "jwt-decode": "^1.1.0",
    "keymirror": "^0.1.1",
    "lodash": "4.0.0",
    "log4js": "^0.6.38",
    "material-ui": "~0.15.4",
    "mongoose": "^4.3.4",
    "morgan": "^1.2.3",
    "normalize.css": "^4.2.0",
    "pg": "^4.5.5",
    "react": "15.3.2",
    "react-infinite": "^0.9.2",
    "react-input-field": "^1.2.4",
    "react-mixin": "^1.1.0",
    "react-router": "^0.13.2",
    "react-star-rating": "^1.4.2",
    "react-tap-event-plugin": "~0.2.2",
    "react-toolbox": "^1.2.1",
    "react-virtual-list": "^1.8.0",
    "reqwest": "2.0.5",
    "when": "^3.7.2"
  "devDependencies": {
    "babelify": "^6.1.0",
    "browser-sync": "^2.1.6",
    "browserify": "^8.0.3",
    "clean-css": "^3.1.9",
    "eslint": "^0.14.1",
    "nodemon": "^1.5.0",
    "rework": "^1.0.1",
    "rework-npm": "^1.0.0",
    "rework-npm-cli": "^0.1.1",
    "serve": "^1.4.0",
    "uglify-js": "^2.4.15",
    "watchify": "^2.1.1"
2016-10-01 09:30
by Daljeet Virdi
I am having this same problem. In a more condensed form: I'm being told v15.3.2 does not satisfy peer dependency ^0.14.8 || ^15.0.1 —— which is just wrong, it does satisfy that semver range - davidtheclark 2016-10-01 13:59
Could you cut all the npm warnings from your first code block? Those are kind of irrelevant: the errors are the issue - davidtheclark 2016-10-01 14:02
i thought the warnings may provide insight into dealing with the errors - Daljeet Virdi 2016-10-01 17:06
it worked when i updated npm "npm install npm -g" and then downgraded react to; "react": "15.3.0", cleared cache: npm cache clear, removed node_modules, rm -rf node_modules, and reinstalled, npm install - Daljeet Virdi 2016-10-01 17:42


it worked when I:

  1. updated npm "npm install npm -g"
  2. downgraded react to; "react": "15.3.0"
  3. cleared cache: npm cache clear
  4. removed node_modules, rm -rf node_modules,
  5. reinstalled node_modules, npm install.
2016-10-02 17:34
by Daljeet Virdi
sudo npm install npm -g did the trick. Thanks - Parag Tyagi -morpheus- 2016-12-06 07:51
What does npm install npm -g actually do? Installs npm package from npm - Jagi 2016-12-12 14:18
@Jagi it updates npm to latest version - Teodors 2016-12-28 23:39
doesnt work at al - nolawi petros 2017-02-22 23:40


Just update node package manager (npm) to the latest version.

npm install npm -g
2017-01-03 23:50
by Angel Garcia


I was facing the same issue and I used following things:

1. Update the react version: "react": ^16.2.0" in package.json file
2. Delete the node modules by rm -rf node_modules
3. Run npm install
4. npm update

This worked for me.

2018-04-10 06:30
by Murtaza Manasawala