Node Sass could not find a binding for your current environment

Go To StackoverFlow.com

336

I am having issues building an app because node-sass keeps failing with the error.

ERROR in Missing binding /Users/warren/Sites/random-docs/my-cms/node_modules/node-sass/vendor/darwin-x64-11/binding.node
Node Sass could not find a binding for your current environment: OS X 64-bit with Node 0.10.x

I have tried running

npm rebuild node-sass

which says

Binary is fine; exiting.

When running node -v I get v6.2.2

Which is different to what the sass error says "Node 0.10.x". I cant figure out why it is getting the wrong version. I have also tried removing the node_modules folder and running npm update or npm install, both of which did not resolve the issue. Any ideas?

2016-06-23 08:57
by wazzaday
Are you using a node version manager such as nvm? If you are sometimes it messes up some of the npm module paths and they try using a version, different that the current one. If not you could always try removing the node_modules folder and installing the dependencies agai - Vasil Dininski 2016-06-23 09:06
Hey im not using nvm and I tried the removal/re-install step. no luck - wazzaday 2016-06-23 09:17
what is your development environment? you use VS.NET 2105 - Mike Anderson 2016-12-09 13:38
@VasilDininski I'm using nvm, what should I do - Subkhan Sarif 2017-04-25 06:12
What error message did you receive? And what is your dev environment - Vasil Dininski 2017-04-25 07:47
Have you tried removing your ~/.node-gyp or ~/.npm folder? Mentioned below - prasanthv 2017-11-14 20:09
I've tried deleting the node_modules directory and also running npm install, followed by npm rebuild node-sass --force, but to of no avail. I installed node via npm. But, for some reason, my build environment thinks I need a Linux build even though I'm running on Mac OS X: ```Module build failed: Error: Missing binding /frontend/node_modules/node-sass/vendor/linux-x64-57/binding.node Node Sass could not find a binding for your current environment: Linux 64-bit with Node.js 8.x

Found bindings for the following environments:
  - OS X 64-bit with Node.js 8.x```
< - ayl 2018-07-03 04:16


518

I had the same problem

There is an error in your gulpfile:
Error: Missing binding E:\allapp\badshaindiancuisine\node_module\node-sass\vendor\win32-x64-46\binding.node
Node Sass could not find a binding for your current environment:Windows 64-bit with Node.js 4.x

Found bindings for the following environment:
    - OS X 64-bit with Node.js 4.x

How to solve my problem

By going into project folder and then execute:

npm rebuild node-sass
2016-11-08 08:08
by Bipon Biswas
Worked initially but was still having problems. So, I went to /usr/local/lib/ using CMD+SHIFT+G in finder and renamed node-sass folder. Then ran npm install node-sass -g. that fixed. I'm on Mac O - IsmailS 2018-01-16 06:34
This perfectly worked on windows 10 x64 - Hitori 2018-07-16 07:08
I was facing this issue after updating nodejs to 8.x.x and this solved it. Thanks much! Appreciated - ChiragMS 2018-07-18 04:06
Doesn't work. Node: v10.7.0 node-sass: v3.13.1. Says my current environment is 32 bit windows with node 0.10.x which is simply not true - Bardicer 2018-08-01 21:43
This worked in windows 7 with node 10.14 LTS and npm 6.4.1 - santon 2018-12-07 03:04
Worked for me. I think I upgraded node the other day and consequently node-sass stopped working. I ran npm rebuild node-sass and it worked - Martin James 2019-02-03 10:11
Didn't work for me - rebuilding just said it was fine and exite - Anton v B 2019-02-27 08:25
First step would be to delete your node_modules and run npm install rather than rebuilding your node-sass - Nikhil Nanjappa 2019-02-28 11:47


234

Note I'm using VS 2015, 64-bit Windows 7.

Also works for VS 2017 (from replies to this post)

Task Runner Explorer can't load tasks

For VS 2015

  • Go to: Tools > Options > Projects and Solutions > External Web Tools

For VS 2017(.3)

  • Tools > Options > Projects and Solutions > Web Package Management > External Web Tools (per @nothrow)

In VS 2017, you also need to put $(PATH) above $(VSINSTALLERDIR)\Web\External


  • Reorder so that $(PATH) is above $(DevEnvDir)\Extensions\Microsoft\Web Tools\External

enter image description here


Deleting node_modules and running npm install and then npm rebuild node-sass did nothing.

2017-01-04 00:21
by Rob Scott
If you are using VS2015 you should definitely make the changes described in this answer. It's probably all you will need to do to fix this issue - Bonneville 2017-01-17 02:30
This also worked for a brand new install of VS2017 also - sarin 2017-03-10 14:19
This fixed by issue. @wazzaday I believe this should be the accepted answer for others to find the answer easily - To Ka 2017-05-11 19:24
In VS2017.3, the path to the setting is Tools > Options > Projects and Solutions > Web Package Management > External Web Toolsnothrow 2017-09-06 20:17
This worked out for me also. I'm running VS Professional 201 - Sukhjeevan 2018-01-15 21:24
This fixed my issue (and the rest of my dev team has come across this - I've had some rollback to 5.0 node just to get this working) - James Haug 2018-02-15 17:52
Fantastic answer, I've been having issues with VS2017 and where is grabs external pieces - JoeCo 2018-08-07 20:56
damn!i would never figure it out... all to compile stupid sass with stupid node in stupid javascrip - L.Trabacchin 2018-08-12 07:41
This worked for me after deleting node_modules from the project. (Running VS2017 - ZhaoYiLi 2018-08-16 19:52
If creating a docker image, and receiving this error during the docker build, you must ensure you didn't accidentally include a nodemodules directory from your host drive. You need to have a .dockerignore file containing an exclusion for 'nodemodules', otherwise those files from your hist will be copied into the container during a 'copy . .' command. The when building a node project in the container which is most likely based off a different underlying Os image, it will attempt using the binding node which was copied in from the host OS - which is obviously the wrong one - nemaroller 2019-01-26 20:10


106

I had the same problem in a Windows environment, receiving the following error:

Error: Missing binding C:\Development{ProjectName}\node_modules\node-sass\vendor\win32-ia32-47\binding.node
Node Sass could not find a binding for your current environment: Windows 32-bit with Node.js 5.x
Found bindings for the following environments:
   - Windows 64-bit with Node.js 6.x

None of the npm commands listed in the other answers here (npm install, npm rebuild node-sass, etc.) worked.

Instead, I had to download the missing binding and place it in the appropriate destination folder.

The bindings can be found on git. Match the file with the folder name identified after /node_modules/node-sass/vendor/ in your error message ('darwin-x64-11' in your case, so you'd want the darwin-x64-11_binding.node file).

Create the missing folder in your project (/node_modules/node-sass/vendor/darwin-x64-11), copy the .node file to the new directory, and rename it to binding.node.

Node-sass release URL: https://github.com/sass/node-sass/releases

2016-12-23 16:40
by Beofett
Also worked for me, thanks! Tried cleaning up node_modules, deleting cache, rifraf, rebuild node-sass, rebuild from VS2015 instead of from command line with npm and at the end this fixed it - Artur Carvalho 2017-01-11 19:02
I had to place to file in C:\Users\USERNAME\AppData\Roaming\npm\node_modules\node-sass\vendor\win32-x64-57 - b3wii 2018-01-02 12:52
And each time you set up your project you must redo?seems a bit cumbersom - Jan Ciołek 2018-02-20 12:59
@JanCiołek I only had this happen once, so I never had to redo this. I'm not sure if it was version specific, or if there was just a problem with the specific install, but I found no better solution (the other answers here did not work for me). Cumbersome or not, it seemed to be the necessary solution for some variations of this problem - Beofett 2018-02-20 13:07
@Beofett This bug ate alot of my time,i did all that was mentioned in this thread but i forget to run compilation.Thanks - Jan Ciołek 2018-02-20 13:11
This is the only answer that worker for me, but found my binding in https://github.com/sass/node-sass/releases instead of the linked URL. Cheer - clapas 2018-03-15 10:18
My error says 'linux-x64-57/binding.node' which is not available on the git url that you posted. update: found it : - vipin8169 2018-03-17 22:19
Thank you @Beofett. Your answer saved me to run my Ionic project in Windows and Mac OSX - Marcus Crisostomo 2018-04-09 14:35
I tried using that and now it tells me that it could not find the bindings even though one line later it stated that it found them.. - Chrisstar 2019-01-21 19:39


96

Worked for me:

Just delete the node-sass folder and run npm install.  

2017-07-10 12:09
by Codiee
This works for me too. Clearly a node version conflict. Thanks - Liz Lemon 2018-02-23 07:25
Did have to delete it the following directory: C:\Users\yourusername\AppData\Roaming\npm-cach - Matt 2018-09-06 20:07
This worked! npm rebuild node-sass did not work for me. (Mac with WebStorm - Jackpile 2018-10-11 23:17


66

Just execute the following command:

npm rebuild node-sass --force


In my case it also couldn't find Python.

Following procedure solved the issue (Windows):

npm rebuild node-sass --force
-- cannot find python.exe, if you have Python installed, add it to your path:
set PYTHON=C:\Python27\Python.exe
-- else: download python "Windows x86-64-MSI" installer from https://www.python.org/downloads/release/python-2714/
-- install python
-- at installation start check: add env variable to path
-- after successfull installation:
npm rebuild node-sass --force
-- finished successfully
2018-02-25 14:54
by Legends
In macOS this also worked wel - Karlo A. López 2018-06-18 23:02
The above worked for me, albeit that it occurred twice in two different apps in two different folders. The python install was a one-off (i.e.not needed when I got the error a second time on my other app) and I didn't need the final npm run build command (not explicitly at least) but I did need to run the rebuild --force twice for both my apps - Greg Trevellick 2018-07-20 19:32


17

I had a similar problem and the reason was that there were two versions of Node installed in my machine: one "global" and another one at the project level. Sass will build correctly only if the Gulp build is running under Node.js 4.x version, so make sure you upgrade the version of Node you are using.

PS: If you completely remove the node_modules folder in your project and re-build from scratch, npm will download the correct dependencies for your current system & node version.

2016-08-17 12:21
by Rocío García Luque
thank god for this. I actually tried to downgrade node on my macbook first and then gave up after half an hou - Cpt. Senkfuss 2019-02-15 16:28


15

Fix

npm rebuild node-sass --force

Or, if you are using node-sass within a container:

docker exec <container-id> npm rebuild node-sass --force

Explanation

This error occurs when node-sass does not have the correct binding for the current operating system.

In my experience, it usually happens when you add node_modules directly to the container filesystem in your Dockerfile (or mount them use a Docker volume). This is because your container architecture is often different than your current operating system. For example, I installed node-sass on macOS but my container runs Ubuntu.

If you force node-sass to rebuild from within the container, node-sass will download the correct bindings for the container operating system.

See my repro case to learn more.

2018-05-23 23:13
by Sherwood Callaway
Facing the same issue with different environments: - dev under MacOS for unit tests - dev using docker-compose (for full system interactions) - prod under alpine-based OS ; Mounting (or not) and npm install (or not) in docker is problematic when having architecture dependent modules: getting darwin or linux binaries depending on where you npm i It happens for NodeJS modules like node-sass, or @google-cloud/pubsubLaurent 2018-12-02 19:37


13

in some cases you need to uninstall and install node-sass library. Try:

npm uninstall --save node-sass

and

npm install --save node-sass

look at this its work for me, Stack link here

2017-11-09 09:00
by core114


12

Try to add suffix --force

npm rebuild node-sass --force
2018-01-10 01:12
by user3890355
This worked for me - Johan Foley 2018-01-29 07:23
Worked for me. Thank you - jpcmf80 2018-02-02 16:46


8

I had the same problem with Node v7.4.0 Current (Latest Features).

Did some reading here and downgraded Node to v6.9.4 LTS and after running npm rebuild node-sass it downloaded the binary and everything started working.

Downloading binary from https://github.com/sass/node-sass/releases/download/v3.13.1/win32-x64-48_binding.node
Download complete .] - :
Binary saved to D:\xxx\xxx-xxx\node_modules\node-sass\vendor\win32-x64-48\binding.node
Caching binary to C:\Users\user\AppData\Roaming\npm-cache\node-sass\3.13.1\win32-x64-48_binding.node`

2017-01-22 12:55
by krankuba


7

I had the same problem

    throw new Error(errors.missingBinary());
    ^

Error: Missing binding /path/to/project/node_modules/node-sass/vendor/linux-x64-47/binding.node
Node Sass could not find a binding for your current environment: Linux 64-bit with Node.js 5.x

Found bindings for the following environments:
  - Linux 64-bit with Node 0.10.x
  - Linux 64-bit with Node.js 5.x

That was because I did npm install using a different nodejs version, try deleting node_modules folder installing and starting

cd your_proyect
rm -rf node_modules
npm install
npm start or gulp or whatever

If you are using nvm do

nvm use stable // or your favorite version
// remove node_module directory
npm install
npm start or gulp or whatever
2016-10-03 19:58
by gsalgadotoledo


4

For Visual Studio 2015/2017, Right Click on your package.json and Click on Restore Packages.

This will make sure that the npm from the Visual Studio Tools External Tools is run and the binding will be rebuild based on that.

2017-06-26 16:35
by Sivasankar Sabapathy sivasunke
This is what eventually worked for me - Corv1nus 2018-03-05 14:33
Nice and easy solution, and the only one that worked from the few above that I tried. Thanks - Eli Gassert 2018-05-30 16:07


3

This usually happens because the environment has changed since running npm install. Running npm rebuild node-sass builds the binding for the current environment.

2017-03-29 05:59
by Kisz Na


3

For my particular case none of the above answers worked. So what it worked:

rm -rf node_modules 
rm -rf /tmp/* 
rm -rf /root/.npm/node-sass 
npm uninstall --save node-sass 
npm cache clean --force 

npm cache verify to check that nothing is left in the cache

npm install

Altough I haven't tried to reproduce the sequence it was a combination of the above that worked. In addition you may also try:

npm install --save node-sass or npm install node-sass -g

npm rebuild node-sass
npm install bindings
2018-11-23 12:12
by Alex Pandrea


2

A similar error I encountered with Visual Studio 2015 Community Edition while having created an AspNetCore app was:

Node Sass could not find a binding for your current environment: Windows 32-bit with Node.js 5.x
Found bindings for the following environments:
  - Windows 64-bit with Node.js 6.x
This usually happens because your environment has changed since running `npm install`.
Run `npm rebuild node-sass` to build the binding for your current environment.
    at module.exports ([..]\node_modules\node-sass\lib\binding.js:15:13)
    at Object.<anonymous> ([..]\node_modules\node-sass\lib\index.js:14:35)
    at Module._compile (module.js:397:26)
    at Object.Module._extensions..js (module.js:404:10)
    at Module.load (module.js:343:32)
    at Function.Module._load (module.js:300:12)
    at Module.require (module.js:353:17)
    at require (internal/module.js:12:17)
    at Object.<anonymous> ([..]\node_modules\gulp-sass\index.js:187:21)
    at Module._compile (module.js:397:26)

You can see the from the error above that the cause was from a version mismatch on the bindings for nodejs.

Node Sass could not find a binding for your current environment: Windows 32-bit with Node.js 5.x

Found bindings for the following environments: - Windows 64-bit with Node.js 6.x

The solution I found was to

  • Install the nodejs windows version,
  • Add path for node js (C:\Program Files\nodejs) in External Web Tools (see Rob Scott's answer),
  • Move nodejs path above $(PATH).
2017-02-23 03:49
by Matt R


2

This worked for me Deleting node_modules and then restoring packages from IDE and then npm rebuild node-sass

2017-03-16 00:30
by Nouman Bhatti


2

I'm a Windows 8 user, recently updated Node to v8.11.1 and npm to v6.0.0 and faced similar issue. Nothing worked - npm install -g node-sass@latest or deleting the node-sass directory from the project node_modules/ - none of 'em worked for me.

The Laravel Mix was throwing an error to my browser console saying a missing node: win32-x64-57. I don't know whether it's because a slower internet connection or something, the node was missing during the update.

Hence some of the answers directed me to look at the Node-Sass releases, and I found the solution.

  1. Step 1: Check your node-sass version using the command: npm view node-sass version (the {your version} in step 4)
  2. Step 2: Get to Node-Sass Releases
  3. Step 3: Get your release and find the missing node in the assets listed under every release, and download the file
  4. Step 4: Get to your PC's C:\Users\{User}\AppData\Roaming\npm-cache\node-sass\{your version}\ and put the downloaded .node file inside the version folder

And you are done.

In my case the node-sass version was 4.9.0 and the missing node was win32-x64-57_binding.node, so I downloaded the .node file from 4.9.0 release and followed step 4.

2018-05-04 16:38
by Mayeenul Islam


2

This happens when in your workstation you run an update of Node.js and you are using node-sass globally.

So you should uninstall node-sass globally

npm uninstall -g node-sass

And then you have to install it globally, again

npm install -g node-sass
2018-10-02 09:05
by Domenico
Good explanation - Michael Czechowski 2019-01-24 12:29


1

I had the same issue. I couldn't find any proper working solution in here, so I found mine:

Inspired by @Rob-Scott solution and other pointing that we could have 2 versions of Node.js installed, I went to C:\Program Files (x86)\nodejs and realized that I had a node.js version installed in addition to the VS default installation.

My solution was quite simple:

  • Go to Tools > Options > Projects & solutions > Web package management > External web tools
  • Click on add an entry (most left of the top-right block of buttons)
  • Enter C:\Program Files (x86)\nodejs, validate by pressing enter
  • Bring it at the top of the list
  • Enjoy

Probably Node.js is not set well in the PATH variable, but this is my working very quick solution, my 2 cents :)

2018-05-15 23:16
by Jean


1

When building a docker image and attempting to run it locally I ran into this same issue. You need to add a .dockerignore file with the following: .DS_Store .git .gitignore .idea log/* target tmp node_modules client/node_modules spec/internal/public/assets public/assets

2018-08-17 19:35
by Chris J Boyle
Many people will probably not get this far down in the answers, but if anyone is getting this error in building a docker image and installing node, people are probably including nodemodules from their host file system by mistake (a copy . . comand). A .dockerignore file with nodesmodules within it at the root project level will resolve this - nemaroller 2019-01-26 20:06


1

I had this issue when upgrading from VS 2017 Professional to Enterprise

  1. Close VS
  2. Delete node_modules
  3. Open VS
  4. Right click package.json and select 'restore packages'
2018-08-28 11:42
by dk_french032


1

I had to first choose the new default node version nvm use *** or nvm install *** and then remove all in node_modules in the project and npm i again.

2018-09-21 08:41
by obotezat


1

Just refresh your npm cache and:

npm cache clean --force  
npm install

It always works for me in the same case.

UPD: Your problem may also be by reason of absence of a global sasslib.

npm install -g sass
2019-01-26 19:29
by AlexK


0

I just run npm rebuild instead of npm rebuild node-sass and issue gone.. I don't know what is the magic behind though.

2017-03-10 06:15
by Alien13


0

node-sass runs an install script to download the required binary. If there are no environment variables, .npmrc variables or process arguments set then the binary is determined by using the current process platform, architecture and Node ABI version. Therefore, if you run node install in one application and then try to run node-sass in an application with a different platform/architecture/ABI, the binary won't have been downloaded. The solution is to manually download the binary or to fix the binary version using an environment variable (SASS_BINARY_NAME) or a .npmrc variable (sass_binary_name)

You can see the logic for this in the getBinaryPath function in node-sass\lib\extensions.js

2017-04-19 09:21
by Tevin


0

Check your system: Does your system has 2 different Node.js installation?

If you install node from nodejs, the default installation directory is C:\Program Files\nodejs I had the node version 6.xx installed here.

Check your VS External web tools directory C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\Web\External I had the node version 5.xx installed there.

One work around is :

  • Make backup of C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\Web\External directory.
  • Copy C:\Program Files\nodejs directory content and
  • paste into C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\Web\External Directory.
  • Delete node_modules directory from your solution.
  • Re run the project. If you get error message re run the project second time.

If that does not work

  • Delete node_modules directory from your solution.

NOTE: $ is the command prompt

$  npm install 
…
$ npm run build:dev

Rerun the project.

2017-04-21 03:36
by John Kocer


0

Please also remember to rename the xxx.node file ( in my case win32-x64-51) to binding.node and paste in the xxx folder ( in my case win32-x64-51),

2017-05-02 05:14
by Devdutta Natu


0

For people that switched to nvm from system node, if you haven't removed the ~/.npm and ~/.node-gyp folder this problem can arise since perhaps the node version within ~/.node-gyp could be different.

In any case those folders should be removed.

2017-11-14 18:33
by prasanthv


0

Answer by @core114 suggesting Uninstalling & installing sass package again works fine for manual process but for automated deployment/CI/CD you need more generic approach. What worked for me is for Continuos deployment of different environment is :

  1. removing old node_modules using rimraf before deployment

    rimraf node_modules

  2. Updating sass package in npm package.json & committing to source control.

For next deployment it will automatically refresh sass for all environment.

2017-12-11 11:40
by Pranav Singh


0

The problem for me was that the Task Runner Explorer was targeting the solution of my project. When I changed to the project itself using the drop-down list, next to the Task Runner Explorer refresh button, it showed the relevant tasks.

2018-01-18 15:47
by Lewis Hamill


0

For me it was the maven-war-plugin that applied filters to the files and corrupted the woff files.

<plugin>
<artifactId>maven-war-plugin</artifactId>
<configuration>
    <webResources>
        <resource>
            <directory>dist</directory>
            <filtering>true</filtering>
        </resource>
    </webResources>
</configuration>

Remove <filtering>true</filtering>

Or if you need filtering you can do something like this:

<plugin>
    <artifactId>maven-war-plugin</artifactId>
    <configuration>
        <webResources>
            <resource>
                <directory>dist</directory>
                <excludes>
                    <exclude>assets/**/*</exclude>
                </excludes>
                <filtering>true</filtering>
            </resource>
            <resource>
                <directory>dist</directory>
                <includes>
                    <include>assets/**/*</include>
                </includes>
            </resource>
        </webResources>
    </configuration>
</plugin>
2018-08-23 10:34
by Viktor Eriksson


0

I have tried all methods I've found.

I have noticed some strange behavior of that folder. When I was trying to "cd" to 'node_sass' folder from VS terminal, it told that "Folder was not found", but was seen in Finder.

chmod from VS terminal haven't find folder even with 'sudo' command.

I have chmod-ed from native MacOs terminal and just after have rebuild with node.

2018-11-07 18:03
by diginix


0

  1. Delete node_modules folder.
  2. Install dependencies again. (npm i)
2018-12-28 13:34
by Shivam Kubde


0

None of the install/rebuild solutions resolved the issue for me (using gulp).

Here is how I resolved it:

1) Download the missing binding file from the repository.

2) Rename the file binding.node.

3) Create node_modules/node-sass/vendor/darwin-x64-11 (path from error message) directory if it doesn't exist.

4) Add the binding file to node_modules/node-sass/vendor/darwin-x64-11

2019-01-14 18:23
by Don Peat


0

I fixed this by changing JAVA_HOME from x86 to x64. Maven was running on x86 but node was using x64. Remove /node and /node_modules and build again.

2019-02-14 17:04
by Tomáš Čechvala


-1

  1. Create a new directory in node_modules/node-sass/vendor/linux-x64-46/ .
  2. the download fil from https://github.com/sass/node-sass/releases
    (linux-x64-59_binding.node) based upon your version.
  3. paste it in node_modules/node-sass/vendor/linux-x64-46/ rename it to binding.node
2018-04-05 09:57
by vishwanath singh
although not a good practice, this solution might actually work (when all others fail) so when downvoting, it should be clarified wh - Alex Pandrea 2018-11-23 12:00


-1

For me, when i ran npm install it audited the installed packages and showed "found 1 high severity vulnerability" and by running

npm audit fix

did the trick. Posting if it helps someone.

Update: Sharing my error log:

ERROR in ./src/styles.scss (./node_modules/@angular-devkit/build-angular/src/angular-cli-files/plugins/raw-css-loader.js!./node_modules/postcss-loader/src??embedded!./node_modules/sass-loader/lib/loader.js??ref--14-3!./src/styles.scss)
Module build failed (from ./node_modules/sass-loader/lib/loader.js):
Error: Missing binding ..\node_modules\node-sass\vendor\win32-x64-57\binding.node
Node Sass could not find a binding for your current environment: Windows 64-bit with Node.js 8.x

Found bindings for the following environments:
  - Windows 64-bit with Node.js 10.x

This usually happens because your environment has changed since running `npm install`.
....

It did ask me to

Run `npm rebuild node-sass` to download the binding for your current environment.
2019-01-21 21:12
by narcs
This is not what the question is about - trincot 2019-01-21 21:35


-2

For Mac:

  1. -CMD+SHIFT+G
  2. -/usr/local/lib/node-sass
  3. -right click and renamed: should still the same node-sass
  4. -then run: npm install node-sass -g

that fixed.

2018-03-07 15:17
by sadeq alshaar