How to remove JVM property "https.proxyHost"?

Go To StackoverFlow.com

7

I was using proxy on my system for some purpose. But now I don't have any proxy set on my system as well as from the Android Studio proxy settings I have removed the proxy and set it to no proxy.

But I keep getting the following error:

You have JVM property "https.proxyHost" set to .... This may lead to incorrect behavior. Proxy should be set in Settings|HTTP Proxy

As well when I try to build/sync the Gradle file without proxy server the files doesn't get compiled and says please check your network connection where I have internet connection.

2016-02-20 07:18
by silverFoxA


12

If anyone still looking for the solution to the same, here is what worked for me

JAVA_OPTS="$JAVA_OPTS -DsocksProxyPort"

for removing http proxy ports

Source http://mxw.pl/blog/?p=4

2016-06-08 13:50
by silverFoxA
May you please elaborate, where do i need to type this line - inderbagga 2016-06-29 17:55
Open terminal and type it in... For more information please follow the URL mentioned abov - silverFoxA 2016-06-29 17:57
i already did that. You saved my hours thanks, but after executing this line terminal didn't gave any respons - inderbagga 2016-06-29 18:17
It doesn't return but if no error that means it has been processed successfull - silverFoxA 2016-06-29 18:23
thanks again mat - inderbagga 2016-06-29 18:34
-DsocksProxyPort? Is that the reference article mistyped - ManuQiao 2017-04-19 02:59
It's not but would suggest you to type it n the terminal rather copy pastin - silverFoxA 2017-04-21 04:24
JAVA_OPTS="$JAVA_OPTS -DsocksProxtPort"qinmiao 2017-11-16 03:50
Brother, you just saved me another gruelling hour. I want to send you flowers - Shashank Saxena 2018-04-23 09:35
Make sure to restart Android Studio after making this change - Leon 2019-01-23 09:42


3

Using a Mac:

Go to Network settings -> Advanced -> Proxies and uncheck "proxy server required password" for both HTTP and HTTPS. Remove user name and password.

In IntellJ/Android Studio restart with File -> Invalidate and Restart -> Just Restart

2019-02-01 13:11
by Amresh Deshpande