Folder is locked and I can't unlock it

Go To


When I'm trying to update or commit code from a project it's telling me that the folder is locked. When I try to "release lock" it says that there's nothing to unlock in this working space.

What does that mean? Why I can't update, commit or even clean up the project.

2012-04-04 20:42
by Iyad Al aqel
Which version of svn are you using - Chriseyre2000 2012-04-04 20:44
Assembla for a repository , Tourtise SVN 1. - Iyad Al aqel 2012-04-04 20:46
So do you have a .svn folder in each directory or just the root - Chriseyre2000 2012-04-04 20:53
Have you tried checking out the project again into a separate working copy - Bernard 2012-04-04 21:01
Yes its working if i check it in a different folder , but the database isn't openin - Iyad Al aqel 2012-04-04 21:04
Chris i have only .svn folder in the roo - Iyad Al aqel 2012-04-04 21:06


Right click on your Subversion working directory folder, and select TortoiseSVN->Clean Up from the Context Menu. This will recurse it's way through your working directory and cleanup any incomplete actions, remove the local locks (which is different from using Subversion locking of a file in the repository which lets everyone know about the lock).

If that doesn't work, see if you can find the names of the files that were changed, but not yet committed, save them, and redo the checkout.

2012-04-12 21:11
by David W.
I had this issue and clean up didn't work (failing to clean up because of the local locks), but going up to the parent folder (which was also under version control) and doing the clean up there fixed the problem - Malvineous 2012-06-08 02:11
You can break the local locks by checking Break locks option - aagjalpankaj 2017-03-21 11:43
@Malvineous 's comment is precious. Should post this as an answer - Lazy Ninja 2017-11-20 09:36


If the file was locked by yourself(same svn account), you can follow these steps:

Right click on the locked file or folder, and select TortoiseSVN->Get lock... , and check on "[] Steal the locks" at the bottom left corner of the dialog, click "OK". If it complete successfully, that's ok. When you right click on the file again, you can see TortoiseSVN->Release lock..., click to unlock.

2012-09-11 09:32
by cuixiping


Using svn command line to unlock the local folders, just use svn cleanup.


# svn commit -m "fixing #1234"


# svn st


# svn cleanup


# svn st


# svn commit -m "fixing #1234"


2014-10-18 18:28
by Sebas


To anyone still having this issue (Error: Working copy '{DIR}' locked.), I have your solution:

I found that when one of TortoiseSVN windows crash, it leaves a TSVNCache.exe that still has a few handles to your working copy and that is causing the Lock issues you are seeing (and also prevents Clean Up from doing it's job).

So to resolve this:


1a) Use Process Explorer or similar to delete the handles owned by TSVNCache.exe

1b) ..Or even easier, just use Task Manager to kill TSVNCache.exe


2) Right click -> TortoiseSVN -> Clean up. Only "Clean up working copy status" needs to be checked.

From there, happy updating/committing. You can reproduce Lock behavior by doing SVN Update and then quickly killing it's TortoiseProc.exe process before Update finishes.

2013-03-04 20:51
by Jonathon J Howey


This was the first time I had this issue. I even tried to restart PC, without effect. This solves my problem:

Solution for me:

  1. Right Click on Project Working Directory.
  2. Navigate TortoiseSVN.
  3. Navigate To Clean Up.
  4. Leave all default options, and check Break Locks
  5. Click OK

This works for me. I was able to commit changes.

2016-08-01 22:01
by WilliamK
Checking the Break Locks checkbox fixes my issue - Banketeshvar Narayan 2016-10-13 07:17
This was the solution that worked for me - JS5 2017-04-27 13:26


To unlock a file in your working copy from command prompt that is currently locked by another user, use --force option.

$ svn unlock --force tree.jpg

2014-04-23 05:52
by manav m-n
What if I want to unlock a directory - IgorGanapolsky 2016-08-23 16:14
@IgorGanapolsky Give directory name instead of file name in above comman - manav m-n 2016-08-23 18:36
Have you tried it? It doesn't work - IgorGanapolsky 2016-08-23 18:37
@IgorGanapolsky what error msg are you getting. Let me chec - manav m-n 2016-08-23 18:40
The node is not a file - IgorGanapolsky 2016-08-23 19:24


I had this issue and i have done below steps to resolve it:

  1. Go to parent folder instead of child folder
  2. Select SVN cleanup
  3. Click on OK.

Do this step on parent folder instead of child folder!

It worked for me !

2015-10-21 15:22
by Akhilesh


I was moving a folder up one level and into another folder. My mistake was doing the move from within the parent folder.

Bad example:

pwd -> C:\Repo\ParentDir\
svn move ./DirtoCopy ../AnotherDir

SVN needs to update the parent directory with the deleted folders info.
You have to do it from the common root of the source and destination folders or use full paths.

Good example:

svn move C:\Repo\ParentDir\DirtoCopy C:\Repo\NewLocation
2016-04-18 14:51
by rasky74


I had this problem where I couldn't unlock a file from the client side. I decided to go to the sever side which was much simpler.

On SVN Server:

Locate locks

 svnadmin lslocks /root/of/repo
 (in my case it was var/www/svn/[name of Company])

 You can add a specific path to this by svnadmin lslocks /root/of/repo "path/to/file"

Remove lock

 svnadmin rmlocks /root/of/repo “path/to/file” 

That's it!

2018-11-09 15:42
by Stacker


Solution :

  1. Right Click on Project Working Directory.
  2. Navigate TortoiseSVN.
  3. Navigate To Clean Up.
  4. Select Clean up working copy status(make checked mark)
  5. Click OK
  6. Repeat Step 1 and 2 then navigate to release Lock.
  7. Click OK Your project lock get opened.
2013-12-23 08:59
by Vinayak


In addition to David M's answer, while doing cleanup -> check 'break locks' option. This will ensure release of locks. Then do svn update. This worked for me.

2016-05-18 06:22
by Vinnu


To unlock a blocked document: 1. Right click -> Lock 2. Check the "Steal the locks" check box 2. Release the lock

2016-12-06 12:31
by user7257040


I research a lot on this issue but no solution fix my problem until I try this:

My repo folder is shared with a Windows xp virtual machine, so I execute the clean up from the VM and then execute SVN UPDATE from the host.

It worked for me.

Greetings from Costa Rica.

2017-07-11 16:32
by Luisca94


I had this happen after having Tortoise get corrupted and crash while trying to update folders. I ended up re-installing Tortoise, but the ghost lock was still present. From there I had to delete the folder and do a new checkout. Obviously I got really lucky that I didn't have any new changes to commit at the time. Anyhow, not great news, and if anyone has a better solution I'd love to hear it myself. Even using "Break Lock" ie unlock with the force option did not change anything.

2012-04-12 20:21
by JMM


Clean up, check all check box => This work for me

2013-09-18 02:49
by Đức Thắng Nguyễn
Same as Đức Thắng Nguyễn. Do a "robust" Clean Up - NoName 2015-04-14 11:12


I encountered this problem after these operations:

  1. get lock on folder
  2. modify files
  3. remove files and update folders --> new files downloaded
  4. try to commit or release lock

I finally resolved the problem by forcing the lock again : TortoiseSVN --> Get Lock --> check "steal lock" then commit or release lock.

2015-04-28 16:31
by med_alpa