Change secure storage directory in Eclipse - user.home path issue on Windows

Go To


I have an issue with saving passwords in Eclipse. None of my passwords are "remembered" and I've found Eclipse tries to save them in a folder my Windows account doesn't have access to.

It tries to save to


a directory that does not exist and to which my Win account couldn't write anyway.

What I found is that my user.home variable is set to D:\Users\Administrator. My wild guess is that's because it's the Administrator account that installed Java.

So my question is - can I change the user.home path, or at least change some other properties to force Eclipse Secure Storage to work elsewhere?

edit: so I found a solution here What are the best JVM settings for Eclipse?

I added this to my eclipse.ini:


Which changed my target password storage file.

2012-04-04 18:47
by eagerMoose



Tested on eclipse luna.

2014-07-29 10:57
by ts.tsogtgerel
Great! It's been the only option that made it possible to store all configuration, and eclipse files under the desired location. Thank - jlanza 2017-08-11 16:13


The secure storage location is set by the "eclipse.keyring" setting.

To change the storage location to a configuration folder under the eclipse folder with a relative path, add the following before the "-vmargs" line in the eclipse.ini file:


Otherwise, an absolute path can be used like:


To keep the "secure_storage" file in your user directory, copy it to the location you choose.

Tested with Eclipse Mars.

2015-10-07 10:01
by David Robson


Im not 100% sure but if you add this line

-user c:\some\path

to your eclipse.ini or use it as cmd parameter it should work.

2012-04-04 19:47
by SWoeste
I found my answer here

To change where passwords are stored, I needed to add this to my eclipse.ini

-eclipse.keyring c:\some\path

However, your answer did help my search : - eagerMoose 2012-04-04 20:12


try to add new arg to eclipse.ini to point to your folder

it is the only solution i found

2014-05-21 12:33
by Benjamin Fuentes