SlikSvn: 'svn' is not recognized as an internal or external command in cmd.exe

Go To StackoverFlow.com

0

Computer: windows 7 64bit
SlikSvn is installed. The System variables PATH has the bin folder set correctly:

 ...; C:\Program Files\SlikSvn\bin; ...

If I type "svn" in the Run dialog (by pressing WIN+R), I can see the svn.exe is called in the cmd window.
If I type "cmd" in the Run dialog, a cmd windows opens up. In that window, typing svn shows the error:

 'svn' is not recognized as an internal or external command

Typing PATH comamnd in the cmd window reveals the correct path as seen in the Enviroment Variables.

I even added a new System variables "SVNPATH" with "C:\Program Files\SlikSvn\bin" in it, but it doesn't work neither.

Does anyone have a solution?

2012-04-03 22:49
by AZ.


5

Do you really have a space between the semi-colon and the C: as shown in the question:

...; C:\Program Files\SlikSvn\bin; ...
    ^

If so, that's probably your problem (Windows will not trim such whitespace when searching the path fields).

2012-04-03 23:05
by Michael Burr
Ha, it works after removing the spaces!! Thanks - AZ. 2012-04-03 23:11
I prefer to use the short name of the directory when there are spaces in the directory name, or it's very long: ...;C:\Progra~1\SlikSvn\bin;.... Why did MS have the bright idea of putting programs under the C:\Program Files directory? Why not simply C:\Applications or even C:\Apps? Shorter and no annoying spaces. There's a maximum of 250 characters in directory/file names which means putting C# projects under C:\Documents and Settings\dweintraub\Data\VisualStudio is just asking for trouble - David W. 2012-04-04 04:17
So I misread this comment as I was having the same problem as AZ. I thought you meant to put the space in, as I did not have one. I did and that actually fixed my issue; svn is now running as I type. Safe to say I'm confused - A-Type 2012-06-01 16:47


0

I solved this by quoting the path in PATH like so: "C:\Program Files\SlikSvn\bin\svn". One would think Windows would allow file paths with spaces but apparently not!

2013-11-13 16:44
by Sam