What version of jQuery to use with jQuery Mobile?

Go To StackoverFlow.com

1

The documentation says to use 1.6.4, but we're up to 1.7.2 now.

Can I use the latest version of jQuery with jQuery Mobile?

2012-04-03 22:41
by Phillip Senn


2

You sure can, but not if you want to be fully cross-platform supported. It will work in most browsers but it's not a good idea.

I know from experience that using jQuery Core 1.7.1 with jQuery Mobile 1.0 that you can get white-screens in the BlackBerry OS (5 for sure, I think 6 as well).

I did successfully use jQuery Core 1.7.1 with jQuery Mobile 1.0 for Android and iOS (I didn't notice any issues).

I highly recommend sticking to the jQuery Mobile team's suggested combo. In fact, if you want to start using jQuery Core 1.7+ with jQuery Mobile I suggest using jQuery 1.1.0 RC-1. It's not a final release yet but it's got some really nice updates.

2012-04-03 22:52
by Jasper
Jasper, Thank you for such a well thought out response - Phillip Senn 2012-04-04 18:52


1

If you are using 1.0.x use Jquery 1.6.4. You can use Jquery 1.7.2 only for JQM 1.1RC1.

2012-04-03 22:55
by codaniel
Oh! I didn't know there was a newer version of JQM as well - Phillip Senn 2012-04-04 18:52